[Mac] Xcode 4.2 から 4.1 へダウングレード(downgrade)する方法


Xcode 4.2 から 4.1 へダウングレードしました。

rvm を使って Ruby 1.9.2 をインストールして、いざ rvm requirements してみると、

“Xcode 4.2.1+ users – please be warned – ”

と出て、無理みたいだったので、Xcode 4.2 から Xcode 4.1 にダウングレードしました。
 

Xcode 4.2 から 4.1 にダウングレードする手順

1. Xcode 4.1のインストーラをダウンロードする

xcode_4.1_for_lion.dmg を Resources for Apple Developer からダウンロードします。

Resources for Apple Developers – Apple Developer

ダウンロードするにはDeveloper登録が必要です、(有料)
 

2. Xcode 4.2 をアンインストールする

下記のコマンドを実行します。

$ sudo /Developer/Library/uninstall-devtools --mode=all

3. アプリケーションフォルダ以下の Install Xcode.app を削除

xcode_4.1_for_lion.dmg で、アプリケーションフォルダに Install Xcode.app を作成するために、今あるインストーラー Install Xcode.app を削除します。
 

4. Xcode 4.1 をインストール

xcode_4.1_for_lion.dmg をマウントして、InstallXcodeLion.pkg をダブルクリックして、インストールします。
 

以上です。


参考情報

Xcode4.2から4.1へのダウングレードについて – 実はhokkai7go

How to remove XCode 4.2 and install 4.1 to develop Ruby / Rails on OSX Lion? – Stack Overflow

  1. コメントはまだありません。

  1. トラックバックはまだありません。