[Ruby] WARNING: Nokogiri was built against LibXML version 2.7.3, but has dynamically loaded 2.7.8


Ruby on Rails で sunspot の gem をインストール後、rails g sunspot_rails:install したら Nokogiri と LibXML のあるあるエラーが発生しました。

エラー内容

WARNING: Nokogiri was built against LibXML version 2.7.3, but has dynamically loaded 2.7.8

解決方法

下記の Stack Overflow の質問に書いてあるが、Mac OS の場合だと、Homebrew 経由で、libxml2 libxslt libiconv をインストール後、これらに Path を通して Nokogiri をインストールすればOK.

compilation – WARNING: Nokogiri was built against LibXML version 2.7.7, but has dynamically loaded 2.6.16 – Stack Overflow

libxml2 libxslt libiconv と Nokogiri のインストール方法は、下記を参考にしました。

Nokogiri

以上です。

  1. コメントはまだありません。

  1. トラックバックはまだありません。