[Redmine] Encoding::CompatibilityError (incompatible character encodings: UTF-8 and ASCII-8BIT):


Redmine 1.2.3 にて、下記のようなエラーが発生しました。

Encoding::CompatibilityError (incompatible character encodings: UTF-8 and ASCII-8BIT):

エラーの原因は、Rubyのバージョンが 1.8.7 を使わなければいけないのに、1.9.2 を使っていたせいでした。

Redmineの各バージョンに対応する Ruby, Rails, Rack を正しく指定してインストールしてあげる必要があります。

Redmine をインストールするときに必要な Ruby, Rails, Rack のバージョンを確認できるサイト | CodeNote.net はてなブックマーク - Redmine をインストールするときに必要な Ruby, Rails, Rack のバージョンを確認できるサイト | CodeNote.net

また、Herokuで使うRubyのバージョンを変更するときはこちらの記事を参考にして下さい。

[Heroku] Rubyのバージョンを変更する | CodeNote.net はてなブックマーク - [Heroku] Rubyのバージョンを変更する | CodeNote.net

以上です。

【参考】

Encoding:CompatibilityError When editing Wiki – Redmine はてなブックマーク - Encoding:CompatibilityError When editing Wiki - Redmine

  1. コメントはまだありません。

  1. トラックバックはまだありません。