[CircleCI] Ruby のバージョン指定について


CircleCI の公式ドキュメントに書いてある ruby のバージョンのみ対応しています。

CircleCI

.ruby-version ファイルに ruby-1.9.3 とだけ指定していてパッチレベルが上がったけど、CircleCI は未対応でエラーがでてテストが失敗することがありました。

特に理由がなければ、

ruby-1.9.3-p547

というようにパッチレベルまで指定してあげましょう。

参考情報

CircleCI uses the wrong Ruby version – CircleCI

Configuring CircleCI – CircleCI

  1. コメントはまだありません。

  1. トラックバックはまだありません。