[Ubuntu] Vim-gnome をインストール


Ubuntu に Vim をインストールしました。

$ vim
プログラム 'vim' は以下のパッケージで見つかりました:
 * vim
 * vim-gnome
 * vim-tiny
 * vim-athena
 * vim-gtk
 * vim-nox
次の操作を試してください: sudo apt-get install <選択したパッケージ>

好きな Vim のパッケージをインストールして下さいとのこと。

正直、どれが良いか分からなかったのですが、gvim こと vim-gnome が良いらしいという記事を見かけたので、vim-gnome をインストールすることにします。

・参考:gvimが良い件(´・ω・)ス|falgon ‘s study はてなブックマーク - gvimが良い件(´・ω・)ス|falgon 's study
 

apt-get ではなく、aptitude を使っているので、aptitudeコマンドでインストールしました。

$ sudo aptitude install -y vim-gnome

■ Vim を起動してみる

インストールしたので、早速 Vim を起動してみます。

$ vim

■ gvim を使ってみる

$ gvim
 
(gvim:8235): Gtk-WARNING **: module_path にはテーマ・エンジンがありません: "pixmap",
 
(gvim:8235): Gtk-WARNING **: module_path にはテーマ・エンジンがありません: "pixmap",
 
(gvim:8235): Gtk-WARNING **: module_path にはテーマ・エンジンがありません: "pixmap",
 
(gvim:8235): Gtk-WARNING **: module_path にはテーマ・エンジンがありません: "pixmap",

下記の記事を参考に gtk2-engines-pixbuf をインストールして解決しました。

$ sudo aptitude install -y gtk2-engines-pixbuf

・参考:Ubuntu日本語フォーラム / gvimがハングアップする(11.10) はてなブックマーク - Ubuntu日本語フォーラム / gvimがハングアップする(11.10)

以上です。
 

  1. コメントはまだありません。

  1. トラックバックはまだありません。