カテゴリー : RVM

[RVM] Empty path passed to certificates update, functions stack: requirements_osx_update_openssl_cert_run …

rvm で Ruby version 2.1.3 をインストールすると Empty path passed to certificates update 的なエラーが発生しました。

% rvm install 2.1.3
 
Searching for binary rubies, this might take some time.
Found remote file https://rubies.travis-ci.org/osx/10.9/x86_64/ruby-2.1.3.tar.bz2
Checking requirements for osx_brew.
Certificates in '/usr/local/etc/openssl/cert.pem' are already up to date.
Requirements installation successful.
ruby-2.1.3 - #configure
ruby-2.1.3 - #download
ruby-2.1.3 - #validate archive
ruby-2.1.3 - #extract
ruby-2.1.3 - #validate binary
ruby-2.1.3 - #setup
ruby-2.1.3 - #gemset created /Users/bakorer/.rvm/gems/ruby-2.1.3@global
ruby-2.1.3 - #importing gemset /Users/bakorer/.rvm/gemsets/global.gems......................................................................
ruby-2.1.3 - #generating global wrappers..............
ruby-2.1.3 - #gemset created /Users/bakorer/.rvm/gems/ruby-2.1.3
ruby-2.1.3 - #importing gemsetfile /Users/bakorer/.rvm/gemsets/default.gems evaluated to empty gem list
ruby-2.1.3 - #generating default wrappers..............
/Users/bakorer/.rvm/scripts/functions/support: line 490: 56810 Trace/BPT trap: 5       "$ruby_path" -rrbconfig -e '\
    File.open("'"$config_path"'","w") { |file|
      RbConfig::CONFIG.sort.each{|key,value|
        file.write("#{key.gsub(/\.|-/,"_")}=\"#{value.gsub("$","\\$")}\"\n")
      }
    }
  ' > /dev/null 2>&1
Empty path passed to certificates update, functions stack: requirements_osx_update_openssl_cert_run rvm_requiremnts_fail_or_run_action __rvm_osx_ssl_certs_ensure_for_ruby __rvm_osx_ssl_certs_ensure_for_ruby_except_jruby external_import_setup external_import main

Ruby 2.1.3 を使おうとすると dyld: Library not loaded: /usr/local/lib/libgmp.10.dylib という libgmp が読み込めないというメッセージが表示されてしまいます。

% rvm use 2.1.3
 
Using /Users/bakorer/.rvm/gems/ruby-2.1.3
dyld: Library not loaded: /usr/local/lib/libgmp.10.dylib
  Referenced from: /Users/bakorer/.rvm/rubies/ruby-2.1.3/bin/ruby
  Reason: Incompatible library version: ruby requires version 13.0.0 or later, but libgmp.10.dylib provides version 12.0.0

下記のように disable-binary フラグを付けて再インストールをすると直るようです。

% rvm reinstall 2.1.3 --disable-binary
 
ruby-2.1.3 - #removing rubies/ruby-2.1.3 - please wait
Checking requirements for osx_brew.
Certificates in '/usr/local/etc/openssl/cert.pem' are already up to date.
Requirements installation successful.
Installing Ruby from source to: /Users/bakorer/.rvm/rubies/ruby-2.1.3, this may take a while depending on your cpu(s)...
ruby-2.1.3 - #downloading ruby-2.1.3, this may take a while depending on your connection...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 11.4M  100 11.4M    0     0  5118k      0  0:00:02  0:00:02 --:--:-- 5118k
ruby-2.1.3 - #extracting ruby-2.1.3 to /Users/bakorer/.rvm/src/ruby-2.1.3 - please wait
ruby-2.1.3 - #configuring - please wait
ruby-2.1.3 - #post-configuration - please wait
ruby-2.1.3 - #compiling - please wait
ruby-2.1.3 - #installing - please wait
ruby-2.1.3 - #making binaries executable - please wait
Rubygems 2.2.2 already available in installed ruby, skipping installation, use --force to reinstall.
ruby-2.1.3 - #gemset created /Users/bakorer/.rvm/gems/ruby-2.1.3@global
ruby-2.1.3 - #importing gemset /Users/bakorer/.rvm/gemsets/global.gems - please wait
ruby-2.1.3 - #generating global wrappers - please wait
ruby-2.1.3 - #gemset created /Users/bakorer/.rvm/gems/ruby-2.1.3
ruby-2.1.3 - #importing gemsetfile /Users/bakorer/.rvm/gemsets/default.gems evaluated to empty gem list
ruby-2.1.3 - #generating default wrappers - please wait
ruby-2.1.3 - #adjusting #shebangs for (gem irb erb ri rdoc testrb rake).
Install of ruby-2.1.3 - #complete 
Ruby was built without documentation, to build it run: rvm docs generate-ri
Making gemset ruby-2.1.3 pristine - please wait
Making gemset ruby-2.1.3@global pristine - please wait

以上です。


参考情報

osx – Error when installing Ruby 2.1.3 with RVM – Stack Overflow

[RVM] .rvmrc から .ruby-version と .ruby-gemset に移行すべき

RVM で .rvmrc ファイルで Ruby のバージョンと gemset を切り替えていたのですが、今だとWarningメッセージが表示されるんですね。

You are using '.rvmrc', it requires trusting, it is slower and it is not compatible with other ruby managers,
you can switch to '.ruby-version' using 'rvm rvmrc to [.]ruby-version'
or ignore this warnings with 'rvm rvmrc warning ignore /Users/bakorer/git/myapp/.rvmrc',
'.rvmrc' will continue to be the default project file in RVM 1 and RVM 2,
to ignore the warning for all files run 'rvm rvmrc warning ignore all.rvmrcs'.
 
Using /Users/bakorer/.rvm/gems/ruby-2.0.0-p247 with gemset myapp

どうやら、これからはRubyのバージョン管理システム(rvm, rbenv, rbfu)で設定ファイルを統一する動きがあったそうで、下記のように .ruby-version と .ruby-gemset に分割しておいた方がよさそうです。

.rvmrc ファイル

rvm use ruby-2.0.0-p247@mygemset

↓ .rvmrc を2ファイルに分割します。

.ruby-version ファイル

ruby-2.0.0-p247

.ruby-gemset ファイル

mygemset

もちろん、従来の .rvmrc ファイルも使えるので、その場合、警告を無視するには下記のコマンドを実行すればOKです。

rvm rvmrc warning ignore all.rvmrcs

参考情報

Use rvmrc or ruby-version file to set a project gemset with RVM? – Stack Overflow

.rvmrcから.ruby-gemsetと.ruby-versionに移行 – Qiita [キータ]

Rubyバージョン管理界にも統一球導入?

[Ruby][RVM] mysql2.bundle: [BUG] Segmentation fault

Ruby on Rails のプロジェクトにて、rvm の gemset を再作成(delete → create)後に bundle install して gem をインストールしてから、rails s したら死んだ。

■ エラーメッセージ

% rails s                             
/Users/bakorer/.rvm/gems/ruby-1.9.3-p286@myapp/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle: [BUG] Segmentation fault
ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]
 
zsh: abort      rails s

■ 解決方法

$ rvm get head && rvm reload && rvm repair all

RVM を最新版にすることで解決した。

【参考】ruby – Rails Script Segmentation Fault with RVM – Stack Overflow

[Ruby] rvm pkg install zlib → [ERROR] There is no checksum for xxx

RVM で zlib インストールしようとしたら、チェックサム無いってエラーでインストールできないときの対処方法をメモ。

# rvm pkg install zlib
Fetching zlib-1.2.7.tar.gz to /usr/local/rvm/archives
There is no checksum for 'http://prdownloads.sourceforge.net/libpng/zlib-1.2.7.tar.gz' or 'zlib-1.2.7.tar.gz', it's not possible to validate it.
If you wish to continue with unverified download add '--verify-downloads 1' after the command.
 
 
Please note that it's required to reinstall all installed rubies:
 
    rvm reinstall all --force
    rvm all-gemsets do rvm gemset pristine

下記のようにインストールすればOKです。

rvm --verify-downloads 1 pkg install zlib 
rvm get head

以上です。

【参考】

ruby – RVM pkg install checksum error – Stack Overflow

[RVM] Ruby の version (バージョン) を Update (アップデート)する方法

まず、rvm を最新版にアップデートします。

rvm get latest

rvm を最新に更新します。

rvm get head

アップデートしたrvmの再読み込み

rvm reload

インストール可能なRubyの一覧を見ます。

rvm list known

最後に、Ruby をアップデートします。

rvm upgrade ruby-1.9.3-p0 ruby-1.9.3-p194
Are you sure you wish to upgrade from ruby-1.9.3-p0 to ruby-1.9.3-p194? (Y/n): Y
 
Do you wish to move over aliases? (Y/n): Do you wish to move over wrappers? (Y/n):

参考情報

rvmでRuby 1.9.3 – tamajio tamajio

rvm – qwik.jp/asakusarb

rvmからRubyをアップグレードしてみた(1.9.2-p136→1.9.2-p180) – さかなチキンぱん。