cURL で TLS のバージョンを指定する方法


cURL コマンドで TLS のバージョンを指定して実行する方法をご紹介します。

Linux

cURL で TLS のバージョンを指定してアクセス

TLS1.0

curl --silent --verbose --tlsv1.0 https://example.com/ > /dev/null

TLS1.1

curl --silent --verbose --tlsv1.1 https://example.com/ > /dev/null

TLS1.2

curl --silent --verbose --tlsv1.2 https://example.com/ > /dev/null

以上、cURL で TLS バージョン指定して接続確認したい、現場からお送りしました。

参考情報

  1. コメントはまだありません。

  1. トラックバックはまだありません。